Career Site, Single Sign-On & Candidate page experiencing slowness
Incident Report for Jobvite Operational
Resolved
We have identified and addressed the login and slowness issues.

We apologize for any disruption this may have caused you and your team. If you have any additional questions in relation to these issues, please don't hesitate to contact the Jobvite Support Team at jobvitecares@jobvite.com.
Posted Sep 07, 2017 - 19:23 PDT
Investigating
We have been alerted of a problem with some loading issues for the Candidate and Career Pages as well as some users unable to login if utilizing Single Sign-On (SSO). The team has identified the cause and working to resolve it.
Posted Sep 07, 2017 - 17:50 PDT