Jobvite Service degradation

Incident Report for Jobvite Operational

Resolved

Early on October 20, 2025, Amazon Web Services (AWS) experienced a major outage in its US-EAST-1 (Northern Virginia) region, resulting in widespread disruptions across numerous platforms. Employ Services, along with several of our third-party vendors, were impacted by this outage, leading to intermittent functionality issues and periods of inaccessibility across our systems.
The issue has since been resolved, and our teams continue to actively monitor for any residual effects to ensure full platform stability.
Posted Oct 21, 2025 - 05:08 PDT

Update

Most Jobvite Services have now been restored. however, our resume parsing vendor continues to experience residual issues. As a result, users may still encounter intermittent disruptions with our resume parsing services. We are actively monitoring the situation and will provide further updates as they become available.
Posted Oct 20, 2025 - 14:12 PDT

Update

Our Jobvite Services are showing signs of recovery as AWS continues to resolve their ongoing outage. Most users are now able to log in and navigate the ATS. However, we are still experiencing issues with Onboarding and resume parsing.
We are actively monitoring the situation and will provide additional updates as they become available.
Posted Oct 20, 2025 - 13:53 PDT

Update

Our Jobvite Services are starting to show signs of recovery as AWS continues to recover from their ongoing outage. Most users are now able to login and navigate the ATS but some services and modules may still be limited. We will provide additional updates as soon as they become available.
Posted Oct 20, 2025 - 13:15 PDT

Update

Due to the widespread issues with AWS affecting the US-EAST-1 Region, our Jobvite platform continues to show instability, resulting in intermittent availability. We will provide updates as soon as they become available.
Posted Oct 20, 2025 - 11:21 PDT

Update

Due to the widespread issues with AWS affecting the US-EAST-1 Region, our Jobvite platform is experiencing some instability, resulting in intermittent availability. We will provide updates as soon as they become available.
Posted Oct 20, 2025 - 08:44 PDT

Identified

We are experiencing an outage due to issues with our public cloud provider. Users may expereince intermittent preformance issues within our applications. We will provide updates as soon as they become available.
Posted Oct 20, 2025 - 06:15 PDT
This incident affected: Jobvite Product Line (Career Sites, ATS - Requisitions, ATS - Candidates, CRM, Onboard, Video Platform, API, User / Employee, Reporting, Email, Custom Integrations) and Talemetry Product Line (Career Sites, Apply, Jobs, CRM, Campaign, Reporting, Integrations).