Jobvite ATS — Degraded Performance

Incident Report for Jobvite Operational

Monitoring

An update on this incident: service performance has returned to normal levels. Our team is actively monitoring the platform to ensure stability is maintained. We will provide a final update once we have confirmed full resolution.
Posted Jul 23, 2026 - 15:51 PDT

Update

Our engineering team continues to investigate the intermittent degraded performance that has affected some Jobvite users. We do not yet have a root cause identified, and our investigation is ongoing.

We appreciate your continued patience and will provide another update as our investigation progresses.
Posted Jul 23, 2026 - 15:37 PDT

Update

Investigating — Update

Our engineering team continues to investigate the intermittent degraded performance affecting the Jobvite ATS. We do not yet have a root cause identified, and our investigation is ongoing.

We appreciate your continued patience and will provide another update as our investigation progresses.
Posted Jul 23, 2026 - 06:19 PDT

Investigating

We are currently investigating reports of degraded performance affecting the Jobvite ATS. Users may experience significantly slow page load times (15–45 seconds) when navigating the application, opening candidate profiles, or performing actions such as rejections and status updates. The issue appears to be intermittent.

Our engineering team has been engaged and is actively investigating the root cause.  We apologize for the disruption to your recruiting workflows.
Posted Jul 22, 2026 - 13:46 PDT
This incident affects: Jobvite Product Line (ATS - Requisitions, ATS - Candidates).