Indeed Apply applications

Incident Report for Jobvite Operational

Resolved

This incident has been resolved. We will continue to monitor to ensure no further issues are detected
Posted Feb 06, 2025 - 13:50 PST

Identified

We have identified an issue with applications through Indeed Apply that may be causing errors for some applicants. We are working on a resolution now
Posted Feb 06, 2025 - 10:46 PST
This incident affected: Jobvite Product Line (ATS - Candidates).