Jobvite Delays - Email Delivery

Incident Report for Jobvite Operational

Resolved

This incident has been resolved.
All delayed emails have been successfully reprocessed, and new emails continue to be processed successfully.

An RCA will be provided within 7-10 business days.
Posted Mar 13, 2026 - 04:05 PDT

Update

Email service maintains stability, and new emails triggered will continue to be sent without issue
Our teams are still working to ensure the successful identification and delivery of any emails processed during the initial incident.

Next update: 7:30 am ET or sooner if fully resolved.
Posted Mar 12, 2026 - 16:06 PDT

Monitoring

Mitigation steps have been applied, and email service functionality is returning to normal.

Any new emails triggered should be sent without issue, and our teams are working to ensure the successful delivery of any emails processed during the initial incident.

Next update: 7 pm ET or upon resolution.
Posted Mar 12, 2026 - 13:25 PDT

Identified

We have identified the root cause affecting Email delivery and we are working with our AWS partner to mitigate the issue.

Next update: 5 pm ET or sooner
Posted Mar 12, 2026 - 12:33 PDT

Investigating

We are investigating an issue affecting the sending of emails from the Jobvite platform.
Users may experience delays in the delivery of emails triggered through the application

Next update: 5 pm ET or sooner.
Posted Mar 12, 2026 - 12:21 PDT
This incident affected: Jobvite Product Line (Email).