Jobvite Domestic Telephone Number
Incident Report for Jobvite External
Resolved
We have resolved the issue and our Domestic / North America telephone number is back in service: 855.315.4473 (HIRE)

We apologize for any inconvenience this may have caused.
Posted Oct 22, 2019 - 07:44 PDT
Investigating
We are aware our Domestic /Toll-Free North America telephone number, 855.315.4473 (HIRE), states it is not in service.

While we work to fix this, please call us direct at 1-513-999-2064.

Jobvite International numbers are still available:
-UK Toll-Free at 0800-0868-665
-All other International Customers +1 541-229-1265 (toll charges apply)
Posted Oct 22, 2019 - 07:26 PDT
This incident affected: Other.